[返回电脑前线首页]·[所有跟帖]·[ 回复本帖 ]·[热门原创]·[繁體閱讀]·[版主管理]
VLC播放器更新到3.0.18 增加新格式支持 改进了流媒体表现以及更多
送交者: uanonym[★★声望品衔10★★] 于 2022-12-02 10:47 已读 17726 次  

uanonym的个人频道

VLC被普遍认为是当今最好的媒体播放器之一。几天前发布的一个新版本为该程序的兼容性、稳定性、安全性和格式支持带来了进一步的改进。非营利组织VideoLAN致力于汇集开源的力量来震撼多媒体世界,他们刚刚发布了新版本的VLC媒体播放器。VLC 3.0.18是"Vetinari"代码库的第19次更新,对于休闲用户和该程序的长期粉丝来说都是非常需要的。 6park.com


VideoLAN说,VLC媒体播放器3.0.18增加了对一些格式的支持,改进了自适应流媒体支持,修复了一些崩溃并更新了许多第三方库。新的媒体播放器修复了对一些媒体格式的寻求,改善了文件与老式GPU的兼容性,并补救了选定的SMB协议行为。 6park.com


此外,该更新避免了在只有非常小的项目或失败的项目的情况下出现播放列表实时循环,解决了"许多"与崩溃有关的错误,并增加了对MKV媒体文件内DVBSub的支持。被更新的库和组件列表包括FFmpeg,这是许多媒体相关开源项目的心脏部分--upnp、x265、libsmb2、dav1d、libass、zlib、GnuTLS、mpg123等等都有赖于此。

VLC媒体播放器v3.0.18还更新了处理蓝光(未受保护/解密)光盘的库,最终解决了影响该程序的一个最长期的错误。蓝光(BD-J)菜单现在可以按原定计划工作,尽管根据最近购买的版本进行的一些简短测试,对超高清蓝光光盘的处理依然有点粗糙。

最后,新的VLC包括对多个安全问题的修复,这些问题在最新的官方安全公告中得到了详细说明。修复的漏洞包括一个可能被错误的mp4文件触发的拒绝服务问题(div by 0)(#27202),导致处理多文件时崩溃的漏洞修复(#26930),一个可能被错误的og文件触发的拒绝服务问题(空指针解除引用)(#27294)和vnc模块中潜在的缓冲区溢出,可能通过一个恶意的vnc URL触发远程代码执行(#27335,CVE-2022-41325)。

这四个被修补的漏洞可能被恶意的第三方用来触发VLC的崩溃或任意代码执行的权限,但VideoLAN表示没有已知的漏洞通过这些漏洞进行代码执行。

喜欢uanonym朋友的这个贴子的话, 请点这里投票,“赞”助支持!
[举报反馈]·[ uanonym的个人频道 ]·[-->>参与评论回复]·[用户前期主贴]·[手机扫描浏览分享]·[返回电脑前线首页]
帖子内容是网友自行贴上分享,如果您认为其中内容违规或者侵犯了您的权益,请与我们联系,我们核实后会第一时间删除。

所有跟帖:        ( 主贴楼主有权删除不文明回复,拉黑不受欢迎的用户 )


    用户名:密码:[--注册ID--]

    标 题:

    粗体 斜体 下划线 居中 插入图片插入图片 插入Flash插入Flash动画


         图片上传  Youtube代码器  预览辅助

    打开微信,扫一扫[Scan QR Code]
    进入内容页点击屏幕右上分享按钮

    楼主本栏目热帖推荐:

    >>>>查看更多楼主社区动态...






    [ 留园条例 ] [ 广告服务 ] [ 联系我们 ] [ 个人帐户 ] [ 版主申请 ] [ Contact us ]